Customer loans failed to reach the offer stage due to a database failure

Incident Report for Kueski

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 14:05 CST

Monitoring

The service disruption was caused by a change made to the database, which resulted in the service failure. The change has been rolled back, and the service has been fully restored and is operating normally. Our Engineering team will continue to closely monitor the environment to ensure service stability.
Posted Jul 30, 2026 - 14:02 CST

Update

We are observing improvements in service performance; however, partial service degradation still persists. The Engineering team continues to investigate the root cause of the incident while actively working to fully restore normal operations. We will provide further updates as more information becomes available.
Posted Jul 30, 2026 - 14:00 CST

Identified

We are currently experiencing an issue where loans are not appearing in the offers due to a database failure. Our engineering team has identified the cause and is actively working on a fix. We will share additional updates as they become available.
Posted Jul 30, 2026 - 13:59 CST

Investigating

Kueski Pay is currently unavailable. We understand the critical nature of this service and are treating this as a top priority incident. We appreciate your patience as we work to quickly resolve the issue. Next update in 30 minutes.
Posted Jul 30, 2026 - 13:58 CST
This incident affected: Kueski Pay Service.