Kueski Pay payment method is not working

Incident Report for Kueski

Resolved

The incident affecting payment status notifications in Kueski Pay V2 has been resolved. Our team implemented the necessary corrective actions and completed validation of the service.
Payment status notifications are now being processed and delivered normally, and the Amazon funnel has recovered to expected operating levels. We will continue to monitor the platform closely to ensure service stability.
Posted Jun 15, 2026 - 00:17 CST

Update

Our team continues to work actively to restore normal operation of the affected service. Some payment status notifications may continue to experience delays while investigation and mitigation efforts remain underway.
We will provide another update as soon as more information becomes available.
Posted Jun 14, 2026 - 23:19 CST

Update

We are currently experiencing a service degradation affecting payment status notifications in Kueski Pay V2. Some notification updates may be delayed while our team investigates the issue and works to restore normal operation. We will provide further updates as more information becomes available.
Posted Jun 14, 2026 - 22:46 CST

Update

We are continuing to investigate this issue.
Posted Jun 14, 2026 - 22:39 CST

Investigating

We are currently observing a degradation in service quality for Kueski Pay. Users may experience slower response times or occasional transaction failures. Our team is focused on restoring performance immediately. Next update in 30 minutes.
Posted Jun 14, 2026 - 21:57 CST
This incident affected: Kueski Pay Service.