Partial Service Degradation

Incident Report for Kueski

Resolved

We have successfully addressed the performance degradation affecting Kueski Pay. Service stability and transaction speeds are back to normal. Start Time: 18:03 p.m. End Time: 22:12 p.m.
Posted Jun 08, 2026 - 23:07 CST

Update

We are continuing to investigate this issue.
Posted Jun 08, 2026 - 19:59 CST

Update

Our team has made progress in stabilizing Kueski Pay, but users may still experience occasional transaction timeouts and slow loading. We are applying targeted adjustments to fully restore the expected speed and reliability. The next update will be provided in 30 minutes.
Posted Jun 08, 2026 - 19:58 CST

Update

Our team is working with elevated priority on the degraded performance of Kueski Pay. We are focused on restoring the speed and stability of transactions. The service is still functional but slower than usual. The next update will be provided in 30 minutes.
Posted Jun 08, 2026 - 19:05 CST

Investigating

We are currently observing a degradation in service quality for Kueski Pay. Users may experience slower response times or occasional transaction failures. Our team is focused on restoring performance immediately. Next update in 30 minutes.
Posted Jun 08, 2026 - 18:27 CST
This incident affected: Kueski Pay Service.