Increased Latency Affecting Kueski Pay

Incident Report for Kueski

Resolved

We have successfully addressed the performance degradation affecting Kueski Pay. Service stability and transaction speeds are back to normal. Start Time: 10:47 a.m. End Time: 12:29 p.m.
Posted Feb 22, 2026 - 13:14 CST

Update

Our team is working with elevated priority on the degraded performance of Kueski Pay. We are focused on restoring the speed and stability of transactions. The service is still functional but slower than usual. The next update will be provided in 30 minutes.
Posted Feb 22, 2026 - 11:51 CST

Investigating

We are investigating an issue causing increased latency (slowness) in Kueski Pay, which may impact the checkout experience. We are actively isolating the cause to return to normal performance. Next update in 30 minutes.
Posted Feb 22, 2026 - 11:44 CST
This incident affected: Kueski Pay Service.