Our support teams have resolved the main issue; now, new Kueski Pay transactions are being processed as usual. In parallel, transactions impacted during the incident will be processed gradually. Update will post in the next 30 min.
Posted Oct 22, 2025 - 19:56 CST
Monitoring
Our support teams have resolved the main issue; now, new Kueski Pay transactions are being processed as usual. In parallel, transactions impacted during the incident will be processed gradually. Update will post in the next 30 min.
Posted Oct 22, 2025 - 19:50 CST
Update
The AML team has rolled back the applied values, but they are still in the evaluation stage of purchases. The team continues to work to resolve the root cause. Currently, no more rejected transactions are being seen, but they are still pending an AML verdict.
Posted Oct 22, 2025 - 18:44 CST
Update
Our support teams have identified the root cause of the issue and are actively working on a resolution. We will provide additional updates as soon as more information becomes available.
Posted Oct 22, 2025 - 18:02 CST
Update
We are continuing to investigate this issue.
Posted Oct 22, 2025 - 17:31 CST
Investigating
Kueski Pay is currently unavailable. We understand the critical nature of this service and are treating this as a top priority incident. We appreciate your patience as we work to quickly resolve the issue. Next update in 30 minutes.